TrustPoint Platform Status - Analytics dashboards may be slow or fail to load – Incident details

All systems operational

Analytics dashboards may be slow or fail to load

Resolved
Major outage
Started 14 days ago

Affected

Analytics

Major outage from 8:36 PM to 9:15 PM, Operational from 9:15 PM to 12:00 AM

Updates
  • Resolved
    UTC
    Resolved

    This issue has been resolved. Analytics dashboards are loading normally again and data is up to date.

    No other parts of the platform were affected. Thank you for your patience.

  • Investigating
    UTC
    Investigating

    We're aware of an issue affecting the Analytics section. Dashboards may be slow to load, fail to load, or display data that isn't fully up to date.

    All other parts of the platform — projects, draw requests, documents, and inspections — are unaffected and working normally.

    We've identified the cause and are working on a fix. We'll post an update as soon as service is restored.