TrustPoint Platform Status - Website is down – Incident details

All systems operational

Website is down

Resolved
Major outage
Started about 2 months agoLasted about 2 hours

Affected

Core Application

Major outage from 12:23 PM to 1:57 PM, Operational from 1:57 PM to 2:12 PM

Updates
  • Postmortem
    Postmortem

    Summary: Following a backend update, a CORS configuration issue caused errors for users accessing the application. The issue was identified and resolved within [90 minutes].

    Root cause: A backend deployment introduced a change that affected CORS headers, preventing the frontend from communicating with the API.

    Resolution: The CORS configuration was corrected and deployed. We have identified improvements to our deployment process to prevent recurrence.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating
    We are currently investigating this incident.